Posts by jelly109

    Guter Punkt, Jürg, und vollkommen richtig. Bei Verwendung des USB-Interfaces sieht es ganz anders aus, da ich dort ja keine Pullup-Widerstände zum IMO-Bus hin eingesetzt habe, da die verwendeten Logikbausteine aus der Reihe Low-Power-Schottky stammen:

    Hier ist die Ausgangsstufe sehr niederohmig, also kann man jederzeit jede benutzte Leitung über 10k oder 100k Ohm Widerstände zum Abschluss des IMO-Busses auf 5V, Masse oder, wie oben vorgeschlagen, mit je zwei Widerständen als Spannungsteiler auf beide schalten. So wird jede Leitung auf 2,5V "vorgespannt".

    Danke für den Beitrag, Jürg.


    Du hast einen 2.2kOhm Widerstand nach Masse zum Abschluss angeschlossen, d.h. es fließt, auch wenn nur die Parallelport-Platine alleine angeschlossen ist, ein Strom von 5V über die Pullup-Widerstände auf der Parallelport-Platine über deine 2.2kOhm Widerstände nach Masse. Das Ruhepotential auf einer Signalleitung pendelt sich nahe 0V ein, statt bei nahe 5V, wie vorgesehen.


    Daher hätte ich eher als Abschluss Pullups, als wie bei Dir Pulldowns empfohlen....aber wie gesagt, wenn es funktioniert ist alles gut.

    ja, endlich mal wieder was los ;^)


    ich habe mir die Sache nochmal genau angesehen....wenn ich die Notiz richtig deute, empfiehlt man hier, die Daten und Adressleitungen mit 10kOhm einmal nach 5V und einmal nach Masse abzuschließen, die Signalleitungen nur nach 5V.


    Ich würde zunächst den Abschluss am Ende des Busses an allen Daten-, Adress- und Signalleitungen mit 10kOhm oder 100kOhm nach 5V empfehlen, da genau das ja auch auf der Parallelport Platine so gemacht wird. Dann wären, wenn die Parallelport-Karte im ersten Slot sitzt, Anfang und Ende des Busses mit den gleichen Werten abgeschlossen.


    Aber wie immer gilt: Probieren geht über Studieren. Und dann bitte Erfahrungen hier teilen!

    ha, schneller gefunden als gedacht. Dieser IMO-Nutzer hat mir freundlicherweise eine Skizze geschickt. Er hat dazu geschrieben, dass er diesen Stecker nur auf den letzten Steckplatz der letzten Bus-Erweiterung gesteckt hat, und damit bisher keine Probleme mehr hat. Wenn ich das Foto richtig deute, hat er die Version mit je einem 10kOhm Widerstand zu Plus 5V und Masse gebaut....wäre toll zu hören, ob das bei Dir auch klappt.

    Hallo, Torsten!


    Vielen Dank für die Erklärung, das macht sehr viel mehr Sinn, ihr habt damit die Besetztmeldung sehr viel unempfindlicher gemacht, aber wenn sie trotzdem noch zuverlässig funktioniert, alles gut! Anscheinend habt ihr beleuchtete Waggons oder relativ kleine Übergangswiderstände an den Radreifen, so dass dass die Belegtmeldung auch mit reduzierter Empfindlichkeit noch gut funktioniert.

    Ja, man kann die Busplatinen natürlich schon aneinanderreihen, aber irgendwann werden die Signale verfälscht. Ich hatte einen Benutzer, der hat IMO ebenfalls mit vielen Karten betrieben und die signalführenden Busleitungen auf beiden Seiten des Busses mit Widerständen gegen Masse abgeschlossen....leider weiß ich den Widerstandswert nicht mehr, der benutzt wurde.....ich werde mal suchen, aber vielleicht liest der Nutzer ja mit.....

    Hallo Juerg,


    vermutlich meinst Du "chaotisch zu finden", weil alle Posts in dem gleichen Thread zu finden sind.....ja, da müssen wir als Forumsteilnehmer uns etwas disziplinieren und am besten für jedes neue Thema einen neuen Thread aufmachen....dann kann man die Posts auch besser einem einzigen Thema zuordnen, und findet unter einem hoffentlich vielsagenden Titel auch die entsprechende Unterhaltung.


    Was genau meinst Du mit "Erweiterungen in das Forum/die Cloud stellen"? Bei WinIMO-Funktionsänderungen oder Erweiterungen, die ich für einige IMO-Nutzer mache, gehe ich immer gleich vor: Ich mache einige Testversionen, lasse den IMO-Benutzer, der sie angefordert hat, testen, und wenn alles so funktioniert, wie gewünscht, dann kommt die Version als aktuelle Version auf mein OneDrive Verzeichnis, wo sich jeder die neueste getestete Version runterladen kann. Du kannst den Link darauf am einfachsten in WinIMO unter Hilfe - neueste Version laden finden. Allerdings hat sich schon lange nix mehr getan...


    Wenn Du auch eine Motor-Zusatzplatine für Weichen entworfen hast, poste doch mal den Schaltplan, vielleicht können andere IMO-Benutzer davon profitieren.

    Gratulation, Mobahner! Tolle neue Erweiterung, die vermutlich viele IMO-Bahner nutzen können. Über Servo gestellte Weichen sind einfach wirklichkeitsgetreuer und betriebssicherer. Umso mehr freut es mich, dass die neue Platine voll IMO-kompatibel ist.


    Übrigens:

    - WinIMO besitzt schon lange eine Erweiterung, dass auch alle 16 Weichen benutzt werden können. Die 8. und 16. Weichenausgänge sind ja auf der Original-IMO-Weichenplatine nur nicht verstärkt, könnten aber theoretisch mit leichten Änderungen benutzt werden. Auch die neue Servo-Weichenkarte kann das tun, hierfür gibt es die Möglichkeit, eine Datei weitab.txt einzusetzen, die Adresse und Bit für eine Weichenschaltung gerade und abzweigend für jede Weiche im Detail definiert. Bitte in der WinIMO Anleitung Details nachlesen.

    - Ich habe außerdem gestern eine erste WinIMO Testversion mit einem modifizierten Hardwaretest erstellt, der auch das 8. Bit der Weichenplatinenregister und der neuen Servo-Weichenplatine ansteuern kann. Bei Interesse bitte bei mir melden.

    Hallo, Torsten, sehr schön, das freut mich, wenn IMO nochmal in den Einsatz kommt. Wie Sepp richtig sagt, bitte an Herrn Müller wenden, die Standard-IMO Karten kommen über ihn.


    Anhand der Kommunikation oben verstehe ich immer noch nicht, welche Widerstände tatsächlich geändert worden sind, und auf welchen Wert....da habt ihr wohl "offline" kommuniziert. Könnt ihr das nochmal hier posten, bitte, und welchen Vorteil es gebracht hat?

    Hallo, Beami! danke für die Log-Datei. Also ich würde auf die Datenübertragung über die parallele Schnittstelle als Ursache tippen. Bei mir ist die auch nie richtig stabil gelaufen, daher habe ich mir das USB-Interface gebaut. Bei vielen Benutzern läuft das Parallel-Interface, könnte am PC liegen....


    Bitte versichere Dich, dass wirklich die LPT1 bei Dir verwendet wird, stelle auf jeden Fall auf der Seite Einstellungen-Timer Porttakt auf 1ms und Portdelay auf 40 oder auch mal auf 80 Microsekunden und probiere nochmal, am besten mit Hardwaretest....


    Viel Erfolg!

    Liebe IMO-Fahrer,


    ich sehe leider erst jetzt diese Diskussion über die Widerstände R1-8 auf der ZR-BM Platine.... Also meine Idee bei dieser Schaltung war, dass bei Stromfluß durch einen Lokmotor, Widerstandslack oder eine Wagenbeleuchtung, an den beiden Silizium-Dioden der Gleichrichter in einem Gleisabschnitt, ca 1,4 V Spannung abfallen, die einen Strom durch die Leuchtdiode der Optokoppler fließen läßt. Um eine Zerstörung der Leuchtdiode zu verhindern, habe ich einen 10 Ohm Widerstand vorgesehen, um den Strom durch die LED zu begrenzen. Eine Erhöhung des Widerstandswerts wird den Strom evtl. zu weit reduzieren, sodass die LED eventuell den Optokoppler nicht mehr durchschaltet.....aber Versuch macht kluch ;^) Wenn bei Euch eine Modifizierung bessere Belegtmeldung bewirkt, super, dann macht das! Jede Erfahrung wird hier im Forum immer sehr begrüßt!

    hallo Beami! die WinIMO Version ist immer das Datum der Erstellung. Kannst Du mir die gesamte Versionsnummer nennen, die Du benutzt, bzw. die derjenigen, die Du denkst noch funktioniert? Ich sende Dir gerne eine ältere zu, wenn ich weiß, welche Du gerne hättest.


    Wie Du vielleicht weißt, wurde WinIMO von mir immer aufbauend auf der vorherigen Version verbessert.....eigentlich sollte es keinen Grund geben, dass WinIMO ab einer bestimmten Version nicht mehr funktionieren sollte. Woran genau siehst Du, dass es Probleme gibt und welche sind das?

    Hallo, Herr Richter. Sie finden den Schaltplan der BM-Karte auf Seite 25, Herr Müller hat nun den Schaltplan auch noch oben in seinem Beitrag hinzugefügt. Für 6 Bahnhofsgleise müssen noch einige Bauteile an der BM-Karte ergänzt werden, analog zu den Widerstanden und Transistoren an IC9 in Herrn Müllers Schaltplan oben, aber auch das würde mit einer einzigen BM-Karte funktionieren. Ich würde jedoch auf keinen Fall die Relais direkt an IC9, sondern über Transistoren wie in Herrn Müllers zweitem Vorschlag anschließen.

    Na, das wird so aber nicht funktionieren, Herr Müller, auch zur Einfahrt muss der Schalter Fahrspannung auf das richtige Einfahrtsgleis des Bahnhofs geben (mal abgesehen davon, dass auch die eingezeichteten Abschnittsunterbrechungen auf den Bahnhofsgleisen nicht da sein dürfen, sonst fährt auch bei eingeschalteter Fahrspannung nichts), sonst bleibt der Zug ja beim Übergang vom Vor- auf den Bahnhofsblock stehen...….der soll ja vermutlich bis zum Halteblock des Gleises einfahren, oder?

    Dann muss der Bediener den Schalter wieder ausschalten und bei Ausfahrt wieder den richtigen einschalten..... und da frage ich mich, ob bei diesem Aufwand nicht auch gleich noch die richtige Weichenstellung manuell, statt über diese Schaltung automatisch, geschalten werden kann.....

    Für mich wäre der Aufwand für ausschließlich automatische Weichenschaltung zu hoch, und der Komfort mit der manuellen Ein-/Ausschaltung der Fahrspannung bei Ein- und Ausfahrt zu gering, also entweder alles über IMO steuern, oder alles manuell, aber da kann man sich sicherlich vortrefflich streiten.....

    Interessante Anwendung, Herr Müller, aber die gesamte Schaltung dient nur zum automatischen Schalten der Weichen zum Füllen eines Abstellbahnhofs, richtig? Sowohl bei Einfahrt, als auch bei Ausfahrt muss der Modellbahner die Fahrspannung auf das richtige Gleis schalten und die jeweils anderen Gleise stromlos schalten. Das ist der größte Aufwand, warum er dann nicht auch noch manuell die richtigen Weichen stellen kann, sondern das diese relativ aufwändige Elektronik übernehmen soll, verstehe ich nicht.... Da bin ich der Meinung: Entweder ganz oder garnicht, aber das ist Geschmackssache.

    Walter, meine Frage ursprünglich war, wie müssen H0 Allstrom Motoren, die mit Wechselstrom Trafos gefahren wurden, umgebaut werden, um mit IMO unter PWM Gleichstrom zu funktionieren. Hier gibt es unterschiedliche Allstrom-Motoren (ein oder zwei Statorspulen), aber wenn mich nicht alles täuscht, wurden die meisten Märklinloks mit einer Feldspule betrieben, Schema wie oben im Bild. Hier ergibt sich die Möglichkeit, die Reihenschaltung von Stator- und Rotor-Spulen aufzutrennen und eine der Spulen über einen Gleichrichter mit Strom nur in eine Richtung durchfließen zu lassen, so dass die Polung die Fahrtrichtung entscheidet, oder die Stator-Spule durch einen Feldmagneten zu ersetzen, so dass dieses äußere Feld immer in eine Richtung gerichtet ist. Um Deine Frage zu beantworten: Nein, mit eingebautem Gleichrichter wäre der Trafo ein Gleichspannungsnetzteil mit Plus- und Minus-Pol wie eingezeichnet.