Intelligente Modellbahnsteuerung

  • Hallo Liebe WIN-IMO Nutzer,

    heute möchte ich mich noch mal melden im Bezug auf die Änderung der Wiederstände. Wir haben auf der Zwei-Richtungs-Fahrreglerplatine Dochtermann/Weber haben wir die RN2-RN4 8x 1M gegen RN2-RN4 8x 10 kOhm getauscht. Danach ist wie gesagt der Fehler mit der Bestztmeldung nicht mehr aufgetreten. Kann uns mal Bitte jemand sagen ob es Erfahrungen gibt im Bezug auf die Busverlängerung. Wir haben bereits 15 Platinen verbaut und weitere Platinen werden nicht so richtig erkannt.


    Liebe Grüße

    Torsten

  • Hallo, Torsten!


    Vielen Dank für die Erklärung, das macht sehr viel mehr Sinn, ihr habt damit die Besetztmeldung sehr viel unempfindlicher gemacht, aber wenn sie trotzdem noch zuverlässig funktioniert, alles gut! Anscheinend habt ihr beleuchtete Waggons oder relativ kleine Übergangswiderstände an den Radreifen, so dass dass die Belegtmeldung auch mit reduzierter Empfindlichkeit noch gut funktioniert.

    Ja, man kann die Busplatinen natürlich schon aneinanderreihen, aber irgendwann werden die Signale verfälscht. Ich hatte einen Benutzer, der hat IMO ebenfalls mit vielen Karten betrieben und die signalführenden Busleitungen auf beiden Seiten des Busses mit Widerständen gegen Masse abgeschlossen....leider weiß ich den Widerstandswert nicht mehr, der benutzt wurde.....ich werde mal suchen, aber vielleicht liest der Nutzer ja mit.....

  • ha, schneller gefunden als gedacht. Dieser IMO-Nutzer hat mir freundlicherweise eine Skizze geschickt. Er hat dazu geschrieben, dass er diesen Stecker nur auf den letzten Steckplatz der letzten Bus-Erweiterung gesteckt hat, und damit bisher keine Probleme mehr hat. Wenn ich das Foto richtig deute, hat er die Version mit je einem 10kOhm Widerstand zu Plus 5V und Masse gebaut....wäre toll zu hören, ob das bei Dir auch klappt.

  • Hallo Torsten und Klaus,


    Steht Irgendwo in den alten IMO Insider Heften. Bei mehr als 20 Platinen sollte der letzte BUS-Platz

    mit Widerständen abgeschlossen werden.

    Selber, habe ich die Wiedererstände nach GND, auf einen "BUS Stecker" aufgelötet,

    Dieser Stecker sollte im letzten BUS Platz gesteckt werden.

    Den Widerstands-Wert kann ich leider nicht mehr sagen,

    Ich schaue morgen nochmals nach, sonst weis Herr Müller es sicher .

  • Hallo zusammen,

    da ist ja jede Menge los im Forum. Zum ECB-Bus kann ich sagen, dass ich 2 Backplanes a 10 Steckplätze verbaut habe. Die sind auf der Lötseite mit einem kurzen Flachbandkabel und den entsprechenden Steckerleisten verbunden.

    Platz 1 ist mit der USB Platine belegt, 2 - 13 jeweils abwechselnd mit Fahrregler- und Belegtmelderplatinen, 14 ist frei, auf 15 steckt eine Reglerplatine für 2 Reglerpotis, 16 und 17 sind frei und auf 18 - 20 stecken 3 Weichenplatinen. Das machte bisher keine Probleme. Aber mit den Abschlußwiderständen ist man vermutlich auf der ganz sicheren Seite was Störungen betrifft.

  • ja, endlich mal wieder was los ;^)


    ich habe mir die Sache nochmal genau angesehen....wenn ich die Notiz richtig deute, empfiehlt man hier, die Daten und Adressleitungen mit 10kOhm einmal nach 5V und einmal nach Masse abzuschließen, die Signalleitungen nur nach 5V.


    Ich würde zunächst den Abschluss am Ende des Busses an allen Daten-, Adress- und Signalleitungen mit 10kOhm oder 100kOhm nach 5V empfehlen, da genau das ja auch auf der Parallelport Platine so gemacht wird. Dann wären, wenn die Parallelport-Karte im ersten Slot sitzt, Anfang und Ende des Busses mit den gleichen Werten abgeschlossen.


    Aber wie immer gilt: Probieren geht über Studieren. Und dann bitte Erfahrungen hier teilen!

  • Hallo an Jelly und Alle


    Habe nochmals viele Foren Durchforst,, hunderte Möglichkeiten , wieso es Störsenkungen gibt.

    Ich werde den Eintrag im Insider Heft von IMO doch noch finden.

    Achtung was passiert wenn Du die Abschluss Wiederstände nach 5 VDC statt nach Masse 0 VDC herstellt ???.


    Also ich habe es vor ca. 6-7 Jahren so gelöst:


    Nur am ENDE des BUS den Abschlusstecker mit Wiederstandwert von je 2.2 k-Ohm auf Daten & Adress Leitungen

    nach Masse gelötet. Der Stecker ist der selbe wie für die IMO Platinen. siehe Foto



    Viele Grüsse Jürg

  • Danke für den Beitrag, Jürg.


    Du hast einen 2.2kOhm Widerstand nach Masse zum Abschluss angeschlossen, d.h. es fließt, auch wenn nur die Parallelport-Platine alleine angeschlossen ist, ein Strom von 5V über die Pullup-Widerstände auf der Parallelport-Platine über deine 2.2kOhm Widerstände nach Masse. Das Ruhepotential auf einer Signalleitung pendelt sich nahe 0V ein, statt bei nahe 5V, wie vorgesehen.


    Daher hätte ich eher als Abschluss Pullups, als wie bei Dir Pulldowns empfohlen....aber wie gesagt, wenn es funktioniert ist alles gut.

  • Hallo Klaus,


    Dein Bekannter schreibt ja, je 1 Wiederstand zu + und zu - und nur die Belegten. ?

    Ob es funktioniert weis ich ja nicht, bei andern IMO-Benutzer

    Bei mir sind keine Parallelport-Platine im MO-BUS gesteckt., nur USB-Platine,

    So sollte auch kein Strom fliessen., oder sehe ich es falsch.?

    Bei mir hatte ich trocken getestet, mit allen Platinen, und konnte keinen Fehler feststellen.

    Diesen Abschluss-Wiederstand-Stecker herstellte ich vor ca. 6-7 Jahren, nach altem Insider IMO-Heft. (aber welches ?)

    Ich kläre es nochmals, entweder mit Herrn Müller oder mit Google oder mit alten IMO-Benutzer,

    Natürlich darf das auch Jedermann vom Club sein.


    Was auch Wichtig ist, sind die Verkabelungen zur Anlage, und die Qualität der Stecker und Kabel,

    und die Verlegungen der Daten-,Steuer-, und Stromkabel .


    Gruss

  • Guter Punkt, Jürg, und vollkommen richtig. Bei Verwendung des USB-Interfaces sieht es ganz anders aus, da ich dort ja keine Pullup-Widerstände zum IMO-Bus hin eingesetzt habe, da die verwendeten Logikbausteine aus der Reihe Low-Power-Schottky stammen:

    Hier ist die Ausgangsstufe sehr niederohmig, also kann man jederzeit jede benutzte Leitung über 10k oder 100k Ohm Widerstände zum Abschluss des IMO-Busses auf 5V, Masse oder, wie oben vorgeschlagen, mit je zwei Widerständen als Spannungsteiler auf beide schalten. So wird jede Leitung auf 2,5V "vorgespannt".

  • Danke Klaus, für die viele Themen die Du für die IMO-Mitglieder leistest


    Es gibt in den IMO-Insider Hefte 1995 bis 2012 endliche Tipps für diese Störungen .

    Was man machen könnte "auf könnte" deswegen weil es : Verschieden Anlagen Typen gibt,

    und jede etwas anders Aufgebaut-wird.


    Googlet im Internet nach diesen Themen:

    Schaut nach andern Foren, usw. :


    Macht mehr mit, scheibt: Wo liegt das Anliegen? Was habt Ihr schon gelöst, usw.

    So ist es einfacher für Euch, und Ihr erreicht mehr IMO Benutzer,

    die vielleicht die Lösungen schon haben.

    mfg Amateur

  • Hallöchen an alle,


    Danke für eure Teilnahme an unserem Problem mit dem Busabschluss. Ich kann nur soviel sagen das bereits einige Platinen bereits verbaut sind. Wir haben zwar nur eine Anlage" Bad Sägeberg" in TT,dafür zwei Ebenen und daher 2 verschiedene Ansteuerungen. In unteren Bereich fahren wir von Anfang an ohne Probleme,nur der obere Bereich mit der Zweirichtungsplatine gab es ja die Fehler in der Besetzmeldung,die ja nun beseitigt wurden. Für den unteren Bereich ist noch die Reglerplatine und für den oberen Bereich ebenfalls die Reglerplatine und die Ein/Ausgabeplatine vorgesehen. Da werden wir dann bestimmt an die Belstungsgrenze der Bussteuerung stoßen. So das soll es erstmal wieder von mir gewesen sein.

    Wünsche euch allen einen guten Rutsch und einen schönen Start ins Jahr 2022


    Liebe Grüße Torsten